商品説明の翻訳が完了していない商品については、Google翻訳サービスへのリンクを表示しております。 ただし機械による自動翻訳は必ずしも翻訳結果が正確ではないことにご注意願います。

Powered by

PostSharp Framework v6.0

C# 7.2、.NET Core 2.0と2.1、.NET Standard 2.0をサポート
7月 31, 2018 - 11:06
新バージョン

特徴

New Platforms

  • Support for .NET Core 2.0-2.1 and .NET Standard 2.0 - PostSharp now runs natively under .NET Core 2.0 or later, which means that .NET Core projects are no longer cross-compiled from .NET Framework. Note that PostSharp 6.0 will still build only under Windows.
  • Support for Portable PDB - Now supports portable PDB files as well as "embedded" portable PDBs.
  • Support for C# 7.2 - The new in parameters and ref struct types are now properly handled.
  • Support for CPS-based project systems in Visual Studio - The new project systems, which work with simpler project files and include built-in support for NuGet package references, are now properly supported.

Deprecated Platforms

  • Deprecation of support for Visual Studio 2012 - Please update to VS 2013 or later.
  • Deprecation of support for .NET Core SDK 1.1 - You can still build projects targeting .NET Core 1.1, but using .NET Core SDK 2.0 or later.
PostSharp Framework

PostSharp Framework

アスペクト指向プログラミングで自動的に独自のパターンを記述し、コードの構造を検証

ご質問がありますか?

今すぐ PostSharp Technologies ライセンススペシャリストとライブ チャット