PostSharp Caching の互換性

互換性

Product Type
  • Visual Studio Add-In
Compatible Containers
  • Microsoft Visual Studio 2019
  • Microsoft Visual Studio 2017

必要な環境

The following software components need to be installed before PostSharp can be used:

  • Any of the following versions of Microsoft Visual Studio*:
    • Visual Studio 2017 Update 1 (15.9).
    • Visual Studio 2019.
  • .NET Framework 4.7.2 or later.
  • Any of the following operating systems:
    • Windows 10: any version in mainstream Microsoft support, except LTSB and S editions.
    • On build agents only: Windows Server 2012, Windows Server 2012 R2, Windows Server 2016, Ubuntu 16.04, Ubuntu 18.04, Alpine 3.10, macOS 10.14.
  • Optionally, one of the following versions of .NET Core SDK:
    • .NET Core SDK 2.1 (build 2.1.500 or later).
    • .NET Core SDK 3.1 (build 3.1.100 or later).
    • .NET SDK 5.0 (build 5.0.100 or later).

*The debugging experience may be inconsistent with other IDEs than Visual Studio or when PostSharp Tools for Visual Studio are not installed.